What’s Vulnerable › Vulnerabilities
CVE-2021-4284: OpenMRS HTML Form Entry UI Framework Integration Module cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability classified as problematic has been found in OpenMRS HTML Form Entry UI Framework Integration Module up to 1.x. This affects an unknown part. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.0.0 is able to address this issue. The name of the patch is 811990972ea07649ae33c4b56c61c3b520895f07. It is recommended to upgrade the affected component. The identifier VDB-216873 was assigned to this vulnerability.
Affected products
- OpenMRS HTML Form Entry UI Framework Integration Module: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: OpenMRS HTML Form Entry UI Framework Integration Module 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/openmrs/openmrs-module-htmlformentryui/commit/811990972ea07649ae33c4b56c61c3b520895f07
- https://github.com/openmrs/openmrs-module-htmlformentryui/pull/51
- https://github.com/openmrs/openmrs-module-htmlformentryui/releases/tag/2.0.0
- https://issues.openmrs.org/browse/RA-1424?filter=-1
- https://vuldb.com/?ctiid.216873
- https://vuldb.com/?id.216873
- https://github.com/openmrs/openmrs-module-htmlformentryui/commit/811990972ea07649ae33c4b56c61c3b520895f07
- https://github.com/openmrs/openmrs-module-htmlformentryui/pull/51
- https://github.com/openmrs/openmrs-module-htmlformentryui/releases/tag/2.0.0
- https://issues.openmrs.org/browse/RA-1424?filter=-1
- https://vuldb.com/?ctiid.216873
- https://vuldb.com/?id.216873
Get alerted when CVE-2021-4284 or the next vulnerability affects your stack