What’s Vulnerable › Vulnerabilities
CVE-2021-4285: Nagios NCPA tail.html cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability classified as problematic was found in Nagios NCPA. This vulnerability affects unknown code of the file agent/listener/templates/tail.html. The manipulation of the argument name leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 2.4.0 is able to address this issue. The name of the patch is 5abbcd7aa26e0fc815e6b2b0ffe1c15ef3e8fab5. It is recommended to upgrade the affected component. VDB-216874 is the identifier assigned to this vulnerability.
Affected products
- Nagios Cross Platform Agent: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: Nagios Cross Platform Agent 2.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/NagiosEnterprises/ncpa/commit/5abbcd7aa26e0fc815e6b2b0ffe1c15ef3e8fab5
- https://github.com/NagiosEnterprises/ncpa/pull/834
- https://github.com/NagiosEnterprises/ncpa/releases/tag/v2.4.0
- https://vuldb.com/?ctiid.216874
- https://vuldb.com/?id.216874
- https://github.com/NagiosEnterprises/ncpa/commit/5abbcd7aa26e0fc815e6b2b0ffe1c15ef3e8fab5
- https://github.com/NagiosEnterprises/ncpa/pull/834
- https://github.com/NagiosEnterprises/ncpa/releases/tag/v2.4.0
- https://vuldb.com/?ctiid.216874
- https://vuldb.com/?id.216874
Get alerted when CVE-2021-4285 or the next vulnerability affects your stack