What’s Vulnerable › Vulnerabilities
CVE-2021-4291: OpenMRS Admin UI Module location.gsp cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in OpenMRS Admin UI Module up to 1.5.x. It has been declared as problematic. This vulnerability affects unknown code of the file omod/src/main/webapp/pages/metadata/locations/location.gsp. The manipulation leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is a7eefb5f69f6c50a3bffcb138bb8ea57cb41a9b6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216916.
Affected products
- OpenMRS Admin UI Module: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: OpenMRS Admin UI Module 1.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/openmrs/openmrs-module-adminui/commit/a7eefb5f69f6c50a3bffcb138bb8ea57cb41a9b6
- https://github.com/openmrs/openmrs-module-adminui/pull/61
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.6.0
- https://vuldb.com/?ctiid.216916
- https://vuldb.com/?id.216916
- https://github.com/openmrs/openmrs-module-adminui/commit/a7eefb5f69f6c50a3bffcb138bb8ea57cb41a9b6
- https://github.com/openmrs/openmrs-module-adminui/pull/61
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.6.0
- https://vuldb.com/?ctiid.216916
- https://vuldb.com/?id.216916
Get alerted when CVE-2021-4291 or the next vulnerability affects your stack