What’s Vulnerable › Vulnerabilities
CVE-2021-42917
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.
Affected products
- Kodi: before 19.0 — fixed in 19.0
How to fix
Upgrade to a fixed version: Kodi 19.0. Check the vendor advisory for mitigations.
References
- https://github.com/fuzzard/xbmc/commit/80c8138c09598e88b4ddb6dbb279fa193bbb3237
- https://github.com/xbmc/xbmc/commit/48730b64494798705d46dfccc4029bd36d072df3
- https://github.com/xbmc/xbmc/issues/20305
- https://github.com/xbmc/xbmc/pull/20306
- https://lists.debian.org/debian-lts-announce/2024/01/msg00009.html
- https://github.com/fuzzard/xbmc/commit/80c8138c09598e88b4ddb6dbb279fa193bbb3237
- https://github.com/xbmc/xbmc/commit/48730b64494798705d46dfccc4029bd36d072df3
- https://github.com/xbmc/xbmc/issues/20305
- https://github.com/xbmc/xbmc/pull/20306
- https://lists.debian.org/debian-lts-announce/2024/01/msg00009.html
Get alerted when CVE-2021-42917 or the next vulnerability affects your stack