What’s Vulnerable › Vulnerabilities
CVE-2021-4292: OpenMRS Admin UI Module Manage Privilege Page privilege.gsp cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in OpenMRS Admin UI Module up to 1.4.x. It has been rated as problematic. This issue affects some unknown processing of the file omod/src/main/webapp/pages/metadata/privileges/privilege.gsp of the component Manage Privilege Page. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 4f8565425b7c74128dec9ca46dfbb9a3c1c24911. It is recommended to upgrade the affected component. The identifier VDB-216917 was assigned to this vulnerability.
Affected products
- OpenMRS Admin UI Module: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: OpenMRS Admin UI Module 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/openmrs/openmrs-module-adminui/commit/4f8565425b7c74128dec9ca46dfbb9a3c1c24911
- https://github.com/openmrs/openmrs-module-adminui/pull/58
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.5.0
- https://vuldb.com/?ctiid.216917
- https://vuldb.com/?id.216917
- https://github.com/openmrs/openmrs-module-adminui/commit/4f8565425b7c74128dec9ca46dfbb9a3c1c24911
- https://github.com/openmrs/openmrs-module-adminui/pull/58
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.5.0
- https://vuldb.com/?ctiid.216917
- https://vuldb.com/?id.216917
Get alerted when CVE-2021-4292 or the next vulnerability affects your stack