What’s Vulnerable › Vulnerabilities
CVE-2021-4295: ONC code-validator-api XML CodeValidatorApiConfiguration.java vocabularyValidationConfigurations xml external entity reference
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-29 · updated 2026-06-17
- Weakness: CWE-611
Description
A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. The manipulation leads to xml external entity reference. Upgrading to version 1.0.31 is able to address this issue. The name of the patch is fbd8ea121755a2d3d116b13f235bc8b61d8449af. It is recommended to upgrade the affected component. VDB-217018 is the identifier assigned to this vulnerability.
Affected products
- ONC code-validator-api: before 1.0.31 — fixed in 1.0.31
How to fix
Upgrade to a fixed version: ONC code-validator-api 1.0.31. Check the vendor advisory for mitigations.
References
- https://github.com/onc-healthit/code-validator-api/commit/fbd8ea121755a2d3d116b13f235bc8b61d8449af
- https://github.com/onc-healthit/code-validator-api/pull/97
- https://github.com/onc-healthit/code-validator-api/releases/tag/1.0.31
- https://vuldb.com/?ctiid.217018
- https://vuldb.com/?id.217018
- https://github.com/onc-healthit/code-validator-api/commit/fbd8ea121755a2d3d116b13f235bc8b61d8449af
- https://github.com/onc-healthit/code-validator-api/pull/97
- https://github.com/onc-healthit/code-validator-api/releases/tag/1.0.31
- https://vuldb.com/?ctiid.217018
- https://vuldb.com/?id.217018
Get alerted when CVE-2021-4295 or the next vulnerability affects your stack