What’s Vulnerable › Vulnerabilities
CVE-2021-4297: trampgeek jobe Restapi.php runs_post Privilege Escalation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-01 · updated 2026-06-17
- Weakness: CWE-276
Description
A vulnerability has been found in trampgeek jobe up to 1.6.4 and classified as problematic. This vulnerability affects the function runs_post of the file application/controllers/Restapi.php. The manipulation of the argument sourcefilename leads to an unknown weakness. Upgrading to version 1.6.5 is able to address this issue. The patch is identified as 694da5013dbecc8d30dd83e2a83e78faadf93771. It is recommended to upgrade the affected component. VDB-217174 is the identifier assigned to this vulnerability.
Affected products
- trampgeek jobe: before 1.6.5 — fixed in 1.6.5
How to fix
Upgrade to a fixed version: trampgeek jobe 1.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/trampgeek/jobe/commit/694da5013dbecc8d30dd83e2a83e78faadf93771
- https://github.com/trampgeek/jobe/issues/46
- https://vuldb.com/?ctiid.217174
- https://vuldb.com/?id.217174
- https://github.com/trampgeek/jobe/commit/694da5013dbecc8d30dd83e2a83e78faadf93771
- https://github.com/trampgeek/jobe/issues/46
- https://vuldb.com/?ctiid.217174
- https://vuldb.com/?id.217174
Get alerted when CVE-2021-4297 or the next vulnerability affects your stack