What’s Vulnerable › Vulnerabilities
CVE-2021-43008
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-05 · updated 2026-06-17
Description
Improper Access Control in Adminer versions 1.12.0 to 4.6.2 (fixed in version 4.6.3) allows an attacker to achieve Arbitrary File Read on the remote server by requesting the Adminer to connect to a remote MySQL database.
Affected products
- vrana adminer: from 1.12.0 through 4.6.2
- Debian Linux: 9.0
References
- https://github.com/vrana/adminer/releases/tag/v4.6.3
- https://lists.debian.org/debian-lts-announce/2022/05/msg00012.html
- https://podalirius.net/en/cves/2021-43008/
- https://sansec.io/research/adminer-4.6.2-file-disclosure-vulnerability
- https://www.adminer.org/
- https://github.com/vrana/adminer/releases/tag/v4.6.3
- https://lists.debian.org/debian-lts-announce/2022/05/msg00012.html
- https://podalirius.net/en/cves/2021-43008/
- https://sansec.io/research/adminer-4.6.2-file-disclosure-vulnerability
- https://www.adminer.org/
Get alerted when CVE-2021-43008 or the next vulnerability affects your stack