What’s Vulnerable › Vulnerabilities
CVE-2021-43018: Adobe Photoshop JPEG2000 Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-07 · updated 2026-06-17
- Weakness: CWE-787
Description
Adobe Photoshop versions 23.0.2 and 22.5.4 (and earlier) are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious JPG file.
Affected products
- Adobe Photoshop: from 22.0 before 22.5.4; from 23.0.0 before 23.0.2 — fixed in 22.5.4, 23.0.2
How to fix
Upgrade to a fixed version: Adobe Photoshop 22.5.4, 23.0.2. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/photoshop/apsb21-113.html
- https://helpx.adobe.com/security/products/photoshop/apsb21-113.html
Get alerted when CVE-2021-43018 or the next vulnerability affects your stack