What’s Vulnerable › Vulnerabilities
CVE-2021-43042
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in Kaseya Unitrends Backup Appliance before 10.5.5. A buffer overflow existed in the vaultServer component. This was exploitable by a remote unauthenticated attacker.
Affected products
- Kaseya Unitrends Backup: from 10.0 before 10.5.5 — fixed in 10.5.5
How to fix
Upgrade to a fixed version: Kaseya Unitrends Backup 10.5.5. Check the vendor advisory for mitigations.
References
- https://helpdesk.kaseya.com/hc/en-gb/articles/4412762258961
- https://www.cyberonesecurity.com/blog/exploiting-kaseya-unitrends-backup-appliance-part-1
- https://www.cyberonesecurity.com/blog/exploiting-kaseya-unitrends-backup-appliance-part-2
- https://helpdesk.kaseya.com/hc/en-gb/articles/4412762258961
- https://www.cyberonesecurity.com/blog/exploiting-kaseya-unitrends-backup-appliance-part-1
- https://www.cyberonesecurity.com/blog/exploiting-kaseya-unitrends-backup-appliance-part-2
Get alerted when CVE-2021-43042 or the next vulnerability affects your stack