What’s Vulnerable › Vulnerabilities

CVE-2021-43074

Description

An improper verification of cryptographic signature vulnerability [CWE-347] in FortiWeb 6.4 all versions, 6.3.16 and below, 6.2 all versions, 6.1 all versions, 6.0 all versions; FortiOS 7.0.3 and below, 6.4.8 and below, 6.2 all versions, 6.0 all versions; FortiSwitch 7.0.3 and below, 6.4.10 and below, 6.2 all versions, 6.0 all versions; FortiProxy 7.0.1 and below, 2.0.7 and below, 1.2 all versions, 1.1 all versions, 1.0 all versions may allow an attacker to decrypt portions of the administrative session management cookie if able to intercept the latter.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.4.9, 7.0.4; Fortinet FortiProxy 2.0.8, 7.0.2; Fortinet FortiSwitch 6.4.11, 7.0.4; Fortinet FortiWeb 6.3.17, 7.0.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-43074 or the next vulnerability affects your stack