What’s Vulnerable › Vulnerabilities
CVE-2021-43113
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-15 · updated 2026-06-17
- Weakness: CWE-77
Description
iTextPDF in iText 7 and up to (excluding 4.4.13.3) 7.1.17 allows command injection via a CompareTool filename that is mishandled on the gs (aka Ghostscript) command line in GhostscriptHelper.java.
Affected products
- Debian Linux: 10.0, 11.0
- Apryse iText: from 7.0.0 before 7.1.17 — fixed in 7.1.17
How to fix
Upgrade to a fixed version: Apryse iText 7.1.17. Check the vendor advisory for mitigations.
References
- https://github.com/itext/itext7/releases/tag/7.1.17
- https://github.com/itext/itextpdf/releases/tag/5.5.13.3
- https://lists.debian.org/debian-lts-announce/2023/01/msg00013.html
- https://pastebin.com/BXnkY9YY
- https://www.debian.org/security/2023/dsa-5323
- https://github.com/itext/itext7/releases/tag/7.1.17
- https://github.com/itext/itextpdf/releases/tag/5.5.13.3
- https://lists.debian.org/debian-lts-announce/2023/01/msg00013.html
- https://pastebin.com/BXnkY9YY
- https://www.debian.org/security/2023/dsa-5323
Get alerted when CVE-2021-43113 or the next vulnerability affects your stack