What’s Vulnerable › Vulnerabilities
CVE-2021-43114
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-09 · updated 2026-06-17
Description
FORT Validator versions prior to 1.5.2 will crash if an RPKI CA publishes an X.509 EE certificate. This will lead to RTR clients such as BGP routers to lose access to the RPKI VRP data set, effectively disabling Route Origin Validation.
Affected products
- Debian Linux: 11.0
- Fort Validator Project Fort Validator: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: Fort Validator Project Fort Validator 1.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/NICMx/FORT-validator/commit/274dc14aed1eb9b3350029d1063578a6b9c77b54
- https://github.com/NICMx/FORT-validator/commit/425e0f4037b4543fe8044ac96ca71d6d02d7d8c5
- https://github.com/NICMx/FORT-validator/commit/673c679b6bf3f4187cd5242c31a795bf8a6c22b3
- https://github.com/NICMx/FORT-validator/commit/eb68ebbaab50f3365aa51bbaa17cb862bf4607fa
- https://github.com/NICMx/FORT-validator/releases/tag/1.5.2
- https://www.debian.org/security/2021/dsa-5033
- https://github.com/NICMx/FORT-validator/commit/274dc14aed1eb9b3350029d1063578a6b9c77b54
- https://github.com/NICMx/FORT-validator/commit/425e0f4037b4543fe8044ac96ca71d6d02d7d8c5
- https://github.com/NICMx/FORT-validator/commit/673c679b6bf3f4187cd5242c31a795bf8a6c22b3
- https://github.com/NICMx/FORT-validator/commit/eb68ebbaab50f3365aa51bbaa17cb862bf4607fa
- https://github.com/NICMx/FORT-validator/releases/tag/1.5.2
- https://www.debian.org/security/2021/dsa-5033
Get alerted when CVE-2021-43114 or the next vulnerability affects your stack