What’s Vulnerable › Vulnerabilities
CVE-2021-4326: Imperative Local Command Injection allows Activity Masking
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-01 · updated 2026-06-17
Description
A vulnerability in Imperative framework which allows already-privileged local actors to execute arbitrary shell commands via plugin install/update commands, or maliciously formed environment variables. Impacts Zowe CLI.
Affected products
- Linuxfoundation Zowe: from 1.16.0 before 1.28.2; from 2.0.0 before 2.5.0 — fixed in 1.28.2, 2.5.0
How to fix
Upgrade to a fixed version: Linuxfoundation Zowe 1.28.2, 2.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-4326 or the next vulnerability affects your stack