What’s Vulnerable › Vulnerabilities
CVE-2021-43269
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-20 · updated 2026-06-17
- Weakness: CWE-94
Description
In Code42 app before 8.8.0, eval injection allows an attacker to change a device’s proxy configuration to use a malicious proxy auto-config (PAC) file, leading to arbitrary code execution. This affects Incydr Basic, Advanced, and Gov F1; CrashPlan Cloud; and CrashPlan for Small Business. (Incydr Professional and Enterprise are unaffected.)
Affected products
- Code42: before 8.8.0 — fixed in 8.8.0
How to fix
Upgrade to a fixed version: Code42 8.8.0. Check the vendor advisory for mitigations.
References
- https://support.code42.com/Terms_and_conditions/Code42_customer_support_resources/Code42_security_advisories/Arbitrary_code_execution_via_malicious_Code42_app_proxy_configuration
- https://www.code42.com/r/support/CVE-2021-43269
- https://support.code42.com/Terms_and_conditions/Code42_customer_support_resources/Code42_security_advisories/Arbitrary_code_execution_via_malicious_Code42_app_proxy_configuration
- https://www.code42.com/r/support/CVE-2021-43269
Get alerted when CVE-2021-43269 or the next vulnerability affects your stack