What’s Vulnerable › Vulnerabilities
CVE-2021-43281
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-04 · updated 2026-06-17
- Weakness: CWE-94
Description
MyBB before 1.8.29 allows Remote Code Injection by an admin with the "Can manage settings?" permission. The Admin CP's Settings management module does not validate setting types correctly on insertion and update, making it possible to add settings of supported type "php" with PHP code, executed on Change Settings pages.
Affected products
- mybb: from 1.2.0 before 1.8.29 — fixed in 1.8.29
How to fix
Upgrade to a fixed version: mybb 1.8.29. Check the vendor advisory for mitigations.
References
- https://github.com/mybb/mybb/security/advisories/GHSA-8gxx-vmr9-h39p
- https://github.com/mybb/mybb/security/advisories/GHSA-8gxx-vmr9-h39p
Get alerted when CVE-2021-43281 or the next vulnerability affects your stack