What’s Vulnerable › Vulnerabilities
CVE-2021-43297: Dubbo Hessian cause RCE when parse error
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-10 · updated 2026-06-17
- Weakness: CWE-502
Description
A deserialization vulnerability existed in dubbo hessian-lite 3.2.11 and its earlier versions, which could lead to malicious code execution. Most Dubbo users use Hessian2 as the default serialization/deserialization protocol, during Hessian catch unexpected exceptions, Hessian will log out some imformation for users, which may cause remote command execution. This issue affects Apache Dubbo Apache Dubbo 2.6.x versions prior to 2.6.12; Apache Dubbo 2.7.x versions prior to 2.7.15; Apache Dubbo 3.0.x versions prior to 3.0.5.
Affected products
- Apache Software Foundation Apache Dubbo: from 2.6.0 before 2.6.12; from 2.7.0 before 2.7.15; from 3.0.0 before 3.0.5 — fixed in 2.6.12, 2.7.15, 3.0.5
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Dubbo 2.6.12, 2.7.15, 3.0.5. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/1mszxrvp90y01xob56yp002939c7hlww
- https://lists.apache.org/thread/1mszxrvp90y01xob56yp002939c7hlww
Get alerted when CVE-2021-43297 or the next vulnerability affects your stack