What’s Vulnerable › Vulnerabilities
CVE-2021-43331
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-12 · updated 2026-06-17
- Weakness: CWE-79
Description
In GNU Mailman before 2.1.36, a crafted URL to the Cgi/options.py user options page can execute arbitrary JavaScript for XSS.
Affected products
- Debian Linux: 9.0
- GNU Mailman: before 2.1.36 — fixed in 2.1.36
How to fix
Upgrade to a fixed version: GNU Mailman 2.1.36. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/mailman/+bug/1949401
- https://lists.debian.org/debian-lts-announce/2022/06/msg00011.html
- https://mail.python.org/archives/list/mailman-announce%40python.org/message/I2X7PSFXIEPLM3UMKZMGOEO3UFYETGRL/
- https://bugs.launchpad.net/mailman/+bug/1949401
- https://lists.debian.org/debian-lts-announce/2022/06/msg00011.html
- https://mail.python.org/archives/list/mailman-announce%40python.org/message/I2X7PSFXIEPLM3UMKZMGOEO3UFYETGRL/
Get alerted when CVE-2021-43331 or the next vulnerability affects your stack