What’s Vulnerable › Vulnerabilities
CVE-2021-4334: Fancy Product Designer <= 4.6.9 - Insufficient Authorization to Arbitrary Options Update via fpd_update_options
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-285
Description
The Fancy Product Designer plugin for WordPress is vulnerable to unauthorized modification of site options due to a missing capability check on the fpd_update_options function in versions up to, and including, 4.6.9. This makes it possible for authenticated attackers with subscriber-level permissions to modify site options, including setting the default role to administrator which can allow privilege escalation.
Affected products
- radykal Fancy Product Designer: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: radykal Fancy Product Designer 4.7.0. Check the vendor advisory for mitigations.
References
- https://support.fancyproductdesigner.com/support/discussions/topics/13000029981
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ea097cb7-85f4-4b6d-9f29-bc2636993f21?source=cve
- https://support.fancyproductdesigner.com/support/discussions/topics/13000029981
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ea097cb7-85f4-4b6d-9f29-bc2636993f21?source=cve
Get alerted when CVE-2021-4334 or the next vulnerability affects your stack