What’s Vulnerable › Vulnerabilities
CVE-2021-4335: Fancy Product Designer <= 4.6.9 - Insufficient Authorization on Mulitple AJAX Actions
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-285
Description
The Fancy Product Designer plugin for WordPress is vulnerable to unauthorized access to data and modification of plugin settings due to a missing capability check on multiple AJAX functions in versions up to, and including, 4.6.9. This makes it possible for authenticated attackers with subscriber-level permissions to modify plugin settings, including retrieving arbitrary order information or creating/updating/deleting products, orders, or other sensitive information not associated with their own account.
Affected products
- radykal Fancy Product Designer: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: radykal Fancy Product Designer 4.7.0. Check the vendor advisory for mitigations.
References
- https://support.fancyproductdesigner.com/support/discussions/topics/13000029981
- https://www.wordfence.com/threat-intel/vulnerabilities/id/644624d8-c193-4ee6-bc82-7ccda5d7f2ac?source=cve
- https://support.fancyproductdesigner.com/support/discussions/topics/13000029981
- https://www.wordfence.com/threat-intel/vulnerabilities/id/644624d8-c193-4ee6-bc82-7ccda5d7f2ac?source=cve
Get alerted when CVE-2021-4335 or the next vulnerability affects your stack