What’s Vulnerable › Vulnerabilities
CVE-2021-43413
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-07 · updated 2026-06-17
Description
An issue was discovered in GNU Hurd before 0.9 20210404-9. A single pager port is shared among everyone who mmaps a file, allowing anyone to modify any files that they can read. This can be trivially exploited to get full root access.
Affected products
- GNU Hurd: before 0.9.20210404-9 — fixed in 0.9.20210404-9
How to fix
Upgrade to a fixed version: GNU Hurd 0.9.20210404-9. Check the vendor advisory for mitigations.
References
- https://lists.gnu.org/archive/html/bug-hurd/2002-11/msg00263.html
- https://lists.gnu.org/archive/html/bug-hurd/2005-06/msg00191.html
- https://lists.gnu.org/archive/html/bug-hurd/2021-05/msg00079.html
- https://www.mail-archive.com/bug-hurd%40gnu.org/msg32113.html
- https://lists.gnu.org/archive/html/bug-hurd/2002-11/msg00263.html
- https://lists.gnu.org/archive/html/bug-hurd/2005-06/msg00191.html
- https://lists.gnu.org/archive/html/bug-hurd/2021-05/msg00079.html
- https://www.mail-archive.com/bug-hurd%40gnu.org/msg32113.html
Get alerted when CVE-2021-43413 or the next vulnerability affects your stack