What’s Vulnerable › Vulnerabilities
CVE-2021-4348: Ultimate GDPR & CCPA <= 2.4 - Unauthenticated Settings Import & Export
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The Ultimate GDPR & CCPA plugin for WordPress is vulnerable to unauthenticated settings import and export via the export_settings & import_settings functions in versions up to, and including, 2.4. This makes it possible for unauthenticated attackers to change plugin settings and conduct attacks such as redirecting visitors to malicious sites.
Affected products
- createit-pl Ultimate GDPR & CCPA Compliance Toolkit for WordPress: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: createit-pl Ultimate GDPR & CCPA Compliance Toolkit for WordPress 2.5. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/critical-vulnerability-in-wordpress-ultimate-gdpr-ccpa-compliance-toolkit-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/40e2e8fb-ea36-4602-bead-8daf75d6dfb9?source=cve
- https://blog.nintechnet.com/critical-vulnerability-in-wordpress-ultimate-gdpr-ccpa-compliance-toolkit-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/40e2e8fb-ea36-4602-bead-8daf75d6dfb9?source=cve
Get alerted when CVE-2021-4348 or the next vulnerability affects your stack