What’s Vulnerable › Vulnerabilities
CVE-2021-43519
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-09 · updated 2026-06-17
- Weakness: CWE-674
Description
Stack overflow in lua_resume of ldo.c in Lua Interpreter 5.1.0~5.4.4 allows attackers to perform a Denial of Service via a crafted script file.
Affected products
- Fedoraproject Fedora: 35
- Lua: from 5.1.0 before 5.3.5; from 5.4.0 before 5.4.4 — fixed in 5.3.5, 5.4.4
How to fix
Upgrade to a fixed version: Lua 5.3.5, 5.4.4. Check the vendor advisory for mitigations.
References
- http://lua-users.org/lists/lua-l/2021-10/msg00123.html
- http://lua-users.org/lists/lua-l/2021-11/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C7XHFYHGSZKL53VCLSJSAJ6VMFGAIXKO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P3EMGAQ5Y6GXJLY4K5DUOOEQT4MZ4J4F/
- http://lua-users.org/lists/lua-l/2021-10/msg00123.html
- http://lua-users.org/lists/lua-l/2021-11/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C7XHFYHGSZKL53VCLSJSAJ6VMFGAIXKO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P3EMGAQ5Y6GXJLY4K5DUOOEQT4MZ4J4F/
Get alerted when CVE-2021-43519 or the next vulnerability affects your stack