What’s Vulnerable › Vulnerabilities
CVE-2021-43529
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-787
Description
Thunderbird versions prior to 91.3.0 are vulnerable to the heap overflow described in CVE-2021-43527 when processing S/MIME messages. Thunderbird versions 91.3.0 and later will not call the vulnerable code when processing S/MIME messages that contain certificates with DER-encoded DSA or RSA-PSS signatures.
Affected products
- Mozilla Thunderbird: before 91.3.0 — fixed in 91.3.0
How to fix
Upgrade to a fixed version: Mozilla Thunderbird 91.3.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=CVE-2021-43529
- https://bugzilla.mozilla.org/show_bug.cgi?id=CVE-2021-43529
Get alerted when CVE-2021-43529 or the next vulnerability affects your stack