What’s Vulnerable › Vulnerabilities
CVE-2021-4353: WooCommerce Dynamic Pricing and Discounts <= 2.4.1 - Unauthenticated Settings Import/Export
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-288
Description
The WooCommerce Dynamic Pricing and Discounts plugin for WordPress is vulnerable to unauthenticated settings export in versions up to, and including, 2.4.1. This is due to missing authorization on the export() function which makes makes it possible for unauthenticated attackers to export the plugin's settings.
Affected products
- RightPress Woocommerce Dynamic Pricing & Discounts: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: RightPress Woocommerce Dynamic Pricing & Discounts 2.4.2. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/woocommerce-dynamic-pricing-and-discounts-plugin-fixed-multiple-vulnerabilities/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5c1e6685-44a7-452e-89ab-b9fffb65a12b?source=cve
- https://blog.nintechnet.com/woocommerce-dynamic-pricing-and-discounts-plugin-fixed-multiple-vulnerabilities/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5c1e6685-44a7-452e-89ab-b9fffb65a12b?source=cve
Get alerted when CVE-2021-4353 or the next vulnerability affects your stack