What’s Vulnerable › Vulnerabilities
CVE-2021-4354: PWA for WP & AMP <= 1.7.32 - Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-434
Description
The PWA for WP & AMP for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the pwaforwp_splashscreen_uploader function in versions up to, and including, 1.7.32. This makes it possible for authenticated attackers to upload arbitrary files on the affected sites server which may make remote code execution possible.
Affected products
- magazine3 PWA for WP – Progressive Web Apps Made Simple: before 1.7.33 — fixed in 1.7.33
How to fix
Upgrade to a fixed version: magazine3 PWA for WP – Progressive Web Apps Made Simple 1.7.33. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/wordpress-pwa-for-wp-and-amp-plugin-fixed-vulnerabilities/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6082791e-feac-41f7-b565-9d98624ddf50?source=cve
- https://blog.nintechnet.com/wordpress-pwa-for-wp-and-amp-plugin-fixed-vulnerabilities/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6082791e-feac-41f7-b565-9d98624ddf50?source=cve
Get alerted when CVE-2021-4354 or the next vulnerability affects your stack