What’s Vulnerable › Vulnerabilities

CVE-2021-43558

Description

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.10.8, 3.11.4, 3.9.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-43558 or the next vulnerability affects your stack