What’s Vulnerable › Vulnerabilities
CVE-2021-43561
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-10 · updated 2026-06-17
- Weakness: CWE-79
Description
An XSS issue was discovered in the google_for_jobs (aka Google for Jobs) extension before 1.5.1 and 2.x before 2.1.1 for TYPO3. The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
Affected products
- Pega-Sus Google For Jobs: before 1.5.1; from 2.0.0 before 2.1.1 — fixed in 1.5.1, 2.1.1
How to fix
Upgrade to a fixed version: Pega-Sus Google For Jobs 1.5.1, 2.1.1. Check the vendor advisory for mitigations.
References
- https://typo3.org/security/advisory/typo3-ext-sa-2021-015
- https://typo3.org/security/advisory/typo3-ext-sa-2021-015
Get alerted when CVE-2021-43561 or the next vulnerability affects your stack