What’s Vulnerable › Vulnerabilities
CVE-2021-43566
- Severity: low (CVSS 2.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-11 · updated 2026-06-17
- Weakness: CWE-362
Description
All versions of Samba prior to 4.13.16 are vulnerable to a malicious client using an SMB1 or NFS race to allow a directory to be created in an area of the server file system not exported under the share definition. Note that SMB1 has to be enabled, or the share also available via NFS in order for this attack to succeed.
Affected products
- Samba: before 4.13.16 — fixed in 4.13.16
How to fix
Upgrade to a fixed version: Samba 4.13.16. Check the vendor advisory for mitigations.
References
- https://bugzilla.samba.org/show_bug.cgi?id=13979
- https://security.netapp.com/advisory/ntap-20220110-0001/
- https://www.samba.org/samba/security/CVE-2021-43566.html
- https://bugzilla.samba.org/show_bug.cgi?id=13979
- https://security.netapp.com/advisory/ntap-20220110-0001/
- https://www.samba.org/samba/security/CVE-2021-43566.html
Get alerted when CVE-2021-43566 or the next vulnerability affects your stack