What’s Vulnerable › Vulnerabilities
CVE-2021-43589
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-24 · updated 2026-06-17
- Weakness: CWE-77
Description
Dell EMC Unity, Dell EMC UnityVSA and Dell EMC Unity XT versions prior to 5.1.2.0.5.007 contain an operating system (OS) command injection Vulnerability. A locally authenticated user with high privileges may potentially exploit this vulnerability, leading to the execution of arbitrary OS commands on the Unity underlying OS, with the privileges of the vulnerable application. Exploitation may lead to an elevation of privilege.
Affected products
- Dell Emc Unity Operating Environment: before 5.1.2.0.5.007 — fixed in 5.1.2.0.5.007
- Dell Emc Unity Xt Operating Environment: before 5.1.2.0.5.007 — fixed in 5.1.2.0.5.007
- Dell Emc Unityvsa Operating Environment: before 5.1.2.0.5.007 — fixed in 5.1.2.0.5.007
How to fix
Upgrade to a fixed version: Dell Emc Unity Operating Environment 5.1.2.0.5.007; Dell Emc Unity Xt Operating Environment 5.1.2.0.5.007; Dell Emc Unityvsa Operating Environment 5.1.2.0.5.007. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000194836/dsa-2021-271-dell-emc-unity-dell-emc-unity-vsa-and-dell-emc-unity-xt-security-update-for-multiple-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000194836/dsa-2021-271-dell-emc-unity-dell-emc-unity-vsa-and-dell-emc-unity-xt-security-update-for-multiple-vulnerabilities
Get alerted when CVE-2021-43589 or the next vulnerability affects your stack