What’s Vulnerable › Vulnerabilities
CVE-2021-43610
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-12 · updated 2026-06-17
- Weakness: CWE-444
Description
Belledonne Belle-sip before 5.0.20 can crash applications such as Linphone via an invalid From header (request URI without a parameter) in an unauthenticated SIP message, a different issue than CVE-2021-33056.
Affected products
- Linphone Belle-Sip: before 5.0.20 — fixed in 5.0.20
How to fix
Upgrade to a fixed version: Linphone Belle-Sip 5.0.20. Check the vendor advisory for mitigations.
References
- https://github.com/BelledonneCommunications/belle-sip/commit/d3f0651531e45e91c2e60f3a16a8b612802e5d2d
- https://github.com/BelledonneCommunications/belle-sip/compare/5.0.18...5.0.20
- https://github.com/BelledonneCommunications/belle-sip/commit/d3f0651531e45e91c2e60f3a16a8b612802e5d2d
- https://github.com/BelledonneCommunications/belle-sip/compare/5.0.18...5.0.20
Get alerted when CVE-2021-43610 or the next vulnerability affects your stack