What’s Vulnerable › Vulnerabilities
CVE-2021-43614: VariableEditSmm: Error checking of UEFI variables could cause buffer overflow, leading to code execution
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-03
- Weakness: CWE-120
Description
Error in handling the PlatformLangCodes UEFI variable could cause a buffer overflow, leading to resource exhaustion and failure.
Affected products
- Insyde Software InsydeH2O: from InsydeH2OUvePkg before 01.01.04.0008 — fixed in 01.01.04.0008
How to fix
Upgrade to a fixed version: Insyde Software InsydeH2O 01.01.04.0008. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-43614 or the next vulnerability affects your stack