What’s Vulnerable › Vulnerabilities
CVE-2021-43637
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-07 · updated 2026-06-17
- Weakness: CWE-120
Description
Amazon WorkSpaces agent is affected by Buffer Overflow. IOCTL Handler 0x22001B in the Amazon WorkSpaces agent below v1.0.1.1537 allow local attackers to execute arbitrary code in kernel mode or cause a denial of service (memory corruption and OS crash) via specially crafted I/O Request Packet.
Affected products
- Amazon Workspaces: before 1.0.1.1537 — fixed in 1.0.1.1537
How to fix
Upgrade to a fixed version: Amazon Workspaces 1.0.1.1537. Check the vendor advisory for mitigations.
References
- https://www.sentinelone.com/labs/usb-over-ethernet-multiple-privilege-escalation-vulnerabilities-in-aws-and-other-major-cloud-services/
- https://www.sentinelone.com/labs/usb-over-ethernet-multiple-privilege-escalation-vulnerabilities-in-aws-and-other-major-cloud-services/
Get alerted when CVE-2021-43637 or the next vulnerability affects your stack