What’s Vulnerable › Vulnerabilities
CVE-2021-4366: PWA for WP & AMP < = 1.7.32 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The PWA for WP & AMP plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the pwaforwp_update_features_options function in versions up to, and including, 1.7.32. This makes it possible for authenticated attackers to change the otherwise restricted settings within the plugin.
Affected products
- magazine3 PWA for WP – Progressive Web Apps Made Simple: before 1.7.33 — fixed in 1.7.33
How to fix
Upgrade to a fixed version: magazine3 PWA for WP – Progressive Web Apps Made Simple 1.7.33. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/wordpress-pwa-for-wp-and-amp-plugin-fixed-vulnerabilities/
- https://wpscan.com/vulnerability/b38a51d7-375e-4cca-88ba-ccab796ac134
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a9892dd1-3939-41a9-a828-fa1bf7d96eb8?source=cve
- https://blog.nintechnet.com/wordpress-pwa-for-wp-and-amp-plugin-fixed-vulnerabilities/
- https://wpscan.com/vulnerability/b38a51d7-375e-4cca-88ba-ccab796ac134
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a9892dd1-3939-41a9-a828-fa1bf7d96eb8?source=cve
Get alerted when CVE-2021-4366 or the next vulnerability affects your stack