What’s Vulnerable › Vulnerabilities
CVE-2021-43755: Adobe After Effects Memory Corruption could lead to Arbitrary Code Execution
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-15 · updated 2026-06-17
- Weakness: CWE-787
Description
Adobe After Effects versions 22.0 (and earlier) and 18.4.2 (and earlier) are affected by an Out-of-bounds Write vulnerability due to insecure handling of a malicious file, potentially resulting in arbitrary code execution in the context of the current user. User interaction is required to exploit this vulnerability.
Affected products
- Adobe After Effects: through 18.4.2; from 22.0 before 22.1.1 — fixed in 22.1.1
How to fix
Upgrade to a fixed version: Adobe After Effects 22.1.1. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/after_effects/apsb21-115.html
- https://helpx.adobe.com/security/products/after_effects/apsb21-115.html
Get alerted when CVE-2021-43755 or the next vulnerability affects your stack