What’s Vulnerable › Vulnerabilities
CVE-2021-43756: Adobe Media Encoder Memory Corruption Vulnerability could lead to Remote Code Execution
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-15 · updated 2026-06-17
- Weakness: CWE-787
Description
Adobe Media Encoder versions 22.0, 15.4.2 (and earlier) are affected by an Out-of-bounds Write vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Media Encoder: before 15.4.2; from 22.0 before 22.1.1 — fixed in 15.4.2, 22.1.1
How to fix
Upgrade to a fixed version: Adobe Media Encoder 15.4.2, 22.1.1. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/media-encoder/apsb21-118.html
- https://helpx.adobe.com/security/products/media-encoder/apsb21-118.html
Get alerted when CVE-2021-43756 or the next vulnerability affects your stack