What’s Vulnerable › Vulnerabilities
CVE-2021-43767
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-25 · updated 2026-06-17
- Weakness: CWE-522
Description
Odyssey passes to client unencrypted bytes from man-in-the-middle When Odyssey storage is configured to use the PostgreSQL server using 'trust' authentication with a 'clientcert' requirement or to use 'cert' authentication, a man-in-the-middle attacker can inject false responses to the client's first few queries. Despite the use of SSL certificate verification and encryption, Odyssey will pass these results to client as if they originated from valid server. This is similar to CVE-2021-23222 for PostgreSQL.
Affected products
- PostgreSQL: from 9.6.0 before 9.6.24; from 10.0 before 10.19; from 11.0 before 11.14; from 12.0 before 12.9; from 13.0 before 13.5; 14.0 — fixed in 10.19, 11.14, 12.9, 13.5, 9.6.24
How to fix
Upgrade to a fixed version: PostgreSQL 10.19, 11.14, 12.9, 13.5. Check the vendor advisory for mitigations.
References
- https://github.com/yandex/odyssey/issues/377%2C
- https://www.postgresql.org/support/security/CVE-2021-23222/
- https://github.com/yandex/odyssey/issues/377%2C
- https://www.postgresql.org/support/security/CVE-2021-23222/
Get alerted when CVE-2021-43767 or the next vulnerability affects your stack