What’s Vulnerable › Vulnerabilities
CVE-2021-43776: XSS vulnerability in @backstage/plugin-auth-backend
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Backstage is an open platform for building developer portals. In affected versions the auth-backend plugin allows a malicious actor to trick another user into visiting a vulnerable URL that executes an XSS attack. This attack can potentially allow the attacker to exfiltrate access tokens or other secrets from the user's browser. The default CSP does prevent this attack, but it is expected that some deployments have these policies disabled due to incompatibilities. This is vulnerability is patched in version `0.4.9` of `@backstage/plugin-auth-backend`.
Affected products
- Linuxfoundation Auth Backend: before 0.4.9 — fixed in 0.4.9
How to fix
Upgrade to a fixed version: Linuxfoundation Auth Backend 0.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/security/advisories/GHSA-w7fj-336r-vw49
- https://github.com/backstage/backstage/tree/master/plugins/auth-backend
- https://github.com/backstage/backstage/security/advisories/GHSA-w7fj-336r-vw49
- https://github.com/backstage/backstage/tree/master/plugins/auth-backend
Get alerted when CVE-2021-43776 or the next vulnerability affects your stack