What’s Vulnerable › Vulnerabilities
CVE-2021-43779: Remote Command Execution vulnerability
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-05 · updated 2026-06-17
- Weakness: CWE-20
Description
GLPI is an open source IT Asset Management, issue tracking system and service desk system. The GLPI addressing plugin in versions < 2.9.1 suffers from authenticated Remote Code Execution vulnerability, allowing access to the server's underlying operating system using command injection abuse of functionality. There is no workaround for this issue and users are advised to upgrade or to disable the addressing plugin.
Affected products
- pluginsGLPI addressing: before 2.9.1 — fixed in 2.9.1
How to fix
Upgrade to a fixed version: pluginsGLPI addressing 2.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/hansmach1ne/MyExploits/tree/main/RCE_GLPI_addressing_plugin
- https://github.com/pluginsGLPI/addressing/commit/6f55964803054a5acb5feda92c7c7f1d91ab5366
- https://github.com/pluginsGLPI/addressing/security/advisories/GHSA-q5fp-xpr8-77jh
- https://github.com/hansmach1ne/CVE-portfolio/tree/main/CVE-2021-43779
- https://github.com/hansmach1ne/MyExploits/tree/main/RCE_GLPI_addressing_plugin
- https://github.com/pluginsGLPI/addressing/commit/6f55964803054a5acb5feda92c7c7f1d91ab5366
- https://github.com/pluginsGLPI/addressing/security/advisories/GHSA-q5fp-xpr8-77jh
Get alerted when CVE-2021-43779 or the next vulnerability affects your stack