What’s Vulnerable › Vulnerabilities
CVE-2021-43783: Path Traversal in @backstage/plugin-scaffolder-backend
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-29 · updated 2026-06-17
- Weakness: CWE-22
Description
@backstage/plugin-scaffolder-backend is the backend for the default Backstage software templates. In affected versions a malicious actor with write access to a registered scaffolder template is able to manipulate the template in a way that writes files to arbitrary paths on the scaffolder-backend host instance. This vulnerability can in some situation also be exploited through user input when executing a template, meaning you do not need write access to the templates. This method will not allow the attacker to control the contents of the injected file however, unless the template is also crafted in a specific way that gives control of the file contents. This vulnerability is fixed in version `0.15.14` of the `@backstage/plugin-scaffolder-backend`. This attack is mitigated by restricting access and requiring reviews when registering or modifying scaffolder templates.
Affected products
- backstage: before 0.15.14 — fixed in 0.15.14
How to fix
Upgrade to a fixed version: backstage 0.15.14. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/f9352ab606367cd9efc6ff048915c70ed3013b7f
- https://github.com/backstage/backstage/security/advisories/GHSA-mg3m-f475-28hv
- https://github.com/backstage/backstage/commit/f9352ab606367cd9efc6ff048915c70ed3013b7f
- https://github.com/backstage/backstage/security/advisories/GHSA-mg3m-f475-28hv
Get alerted when CVE-2021-43783 or the next vulnerability affects your stack