What’s Vulnerable › Vulnerabilities
CVE-2021-43785: Cross Site Scripting Vulnerability in @joeattardi/emoji-button
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-26 · updated 2026-06-17
- Weakness: CWE-79
Description
@joeattardi/emoji-button is a Vanilla JavaScript emoji picker component. In affected versions there are two vectors for XSS attacks: a URL for a custom emoji, and an i18n string. In both of these cases, a value can be crafted such that it can insert a `script` tag into the page and execute malicious code.
Affected products
- joeattardi emoji-button: before 4.6.2 — fixed in 4.6.2
How to fix
Upgrade to a fixed version: joeattardi emoji-button 4.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/joeattardi/emoji-button/commit/05970c09180cd27fff493e998ac5bf0468b1bb16
- https://github.com/joeattardi/emoji-button/commit/fe54bef107eb3f74873a4018f2ff49fa124c6a2e
- https://github.com/joeattardi/emoji-button/security/advisories/GHSA-f34m-x9pj-62vq
- https://github.com/joeattardi/emoji-button/commit/05970c09180cd27fff493e998ac5bf0468b1bb16
- https://github.com/joeattardi/emoji-button/commit/fe54bef107eb3f74873a4018f2ff49fa124c6a2e
- https://github.com/joeattardi/emoji-button/security/advisories/GHSA-f34m-x9pj-62vq
Get alerted when CVE-2021-43785 or the next vulnerability affects your stack