What’s Vulnerable › Vulnerabilities
CVE-2021-4379: WooCommerce Multi Currency <= 2.1.17 - Missing Authorization
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The WooCommerce Multi Currency plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the wmc_bulk_fixed_price function in versions up to, and including, 2.1.17. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to make changes to product prices.
Affected products
- villatheme CURCY - WooCommerce Multi Currency - Currency Switcher: before 2.1.18 — fixed in 2.1.18
How to fix
Upgrade to a fixed version: villatheme CURCY - WooCommerce Multi Currency - Currency Switcher 2.1.18. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/vulnerability-fixed-in-wordpress-woocommerce-multi-currency-plugin/
- https://codecanyon.net/item/woocommerce-multi-currency/20948446
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e2318ae9-4115-442e-9293-a9251787c5f3?source=cve
- https://blog.nintechnet.com/vulnerability-fixed-in-wordpress-woocommerce-multi-currency-plugin/
- https://codecanyon.net/item/woocommerce-multi-currency/20948446
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e2318ae9-4115-442e-9293-a9251787c5f3?source=cve
Get alerted when CVE-2021-4379 or the next vulnerability affects your stack