What’s Vulnerable › Vulnerabilities
CVE-2021-43793: Bypass of Poll voting limits in Discourse
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-01 · updated 2026-06-17
- Weakness: CWE-269
Description
Discourse is an open source discussion platform. In affected versions a vulnerability in the Polls feature allowed users to vote multiple times in a single-option poll. The problem is patched in the latest tests-passed, beta and stable versions of Discourse
Affected products
- discourse: before 2.7.11; 2.8.0-beta1, 2.8.0-beta2, 2.8.0-beta3, 2.8.0-beta4, 2.8.0-beta5, 2.8.0-beta6 (+1) — fixed in 2.7.11
How to fix
Upgrade to a fixed version: discourse 2.7.11. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/0c6b9df77bac9c6f7c7e2eadf6fe100064afdeab
- https://github.com/discourse/discourse/commit/1d0faedfbc3a8b77b971dc70d25e30791dbb6e0b
- https://github.com/discourse/discourse/security/advisories/GHSA-jq7h-44vc-h6qx
- https://github.com/discourse/discourse/commit/0c6b9df77bac9c6f7c7e2eadf6fe100064afdeab
- https://github.com/discourse/discourse/commit/1d0faedfbc3a8b77b971dc70d25e30791dbb6e0b
- https://github.com/discourse/discourse/security/advisories/GHSA-jq7h-44vc-h6qx
Get alerted when CVE-2021-43793 or the next vulnerability affects your stack