What’s Vulnerable › Vulnerabilities
CVE-2021-43797: HTTP fails to validate against control chars in header names which may lead to HTTP request smuggling
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-09 · updated 2026-10-08
- Weakness: CWE-444
Description
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. Netty prior to version 4.1.71.Final skips control chars when they are present at the beginning / end of the header name. It should instead fail fast as these are not allowed by the spec and could lead to HTTP request smuggling. Failing to do the validation might cause netty to "sanitize" header names before it forward these to another remote system when used as proxy. This remote system can't see the invalid usage anymore, and therefore does not do the validation itself. Users should upgrade to version 4.1.71.Final.
Affected products
- Debian Linux: 10.0, 11.0
- NetApp OnCommand Workflow Automation: all versions
- NetApp SnapCenter: all versions
- netty: before 4.1.71 — fixed in 4.1.71
- Oracle Banking Deposits And Lines Of Credit Servicing: 2.7
- Oracle Banking Party Management: 2.7.0
- Oracle Banking Platform: 2.6.2
- Oracle Corporation Oracle Coherence: 12.2.1.4.0, 14.1.1.0.0
- Oracle Communications Cloud Native Core Binding Support Function: 1.11.0
- Oracle Communications Cloud Native Core Network Slice Selection Function: 1.8.0
- Oracle Communications Cloud Native Core Policy: 1.15.0
- Oracle Communications Cloud Native Core Security Edge Protection Proxy: 1.7.0
- Oracle Communications Cloud Native Core Unified Data Repository: 1.15.0
- Oracle Communications Design Studio: 7.4.2
- Oracle Communications Instant Messaging Server: 8.1
- Oracle Corporation Helidon: 1.4.10, 2.4.0
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.58, 8.59
- quarkusio quarkus: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: netty 4.1.71; quarkusio quarkus 2.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/commit/07aa6b5938a8b6ed7a6586e066400e2643897323
- https://github.com/netty/netty/security/advisories/GHSA-wx5j-54mm-rqqq
- https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
- https://security.netapp.com/advisory/ntap-20220107-0003/
- https://www.debian.org/security/2023/dsa-5316
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://github.com/netty/netty/commit/07aa6b5938a8b6ed7a6586e066400e2643897323
- https://github.com/netty/netty/security/advisories/GHSA-wx5j-54mm-rqqq
- https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
- https://security.netapp.com/advisory/ntap-20220107-0003/
- https://www.debian.org/security/2023/dsa-5316
Get alerted when CVE-2021-43797 or the next vulnerability affects your stack