What’s Vulnerable › Vulnerabilities
CVE-2021-4380: Pinterest Automatic <= 4.14.3 - Unuathenticated Arbitrary Options Update
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-284
Description
The Pinterest Automatic plugin for WordPress is vulnerable to authorization bypass due to missing capability checks on the 'wp_pinterest_automatic_parse_request' function and the 'process_form.php' script in versions up to, and including, 1.14.3. This makes it possible for unauthenticated attackers to update arbitrary options on a site that can be used to create new administrative user accounts or redirect unsuspecting site visitors.
Affected products
- ValvePress Pinterest Automatic Pin: before 4.14.4 — fixed in 4.14.4
How to fix
Upgrade to a fixed version: ValvePress Pinterest Automatic Pin 4.14.4. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/critical-vulnerability-fixed-in-wordpress-pinterest-automatic-plugin/
- https://wpscan.com/vulnerability/ffd344fd-de2c-4f27-8932-41aa0a3c3d05
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-pinterest-automatic-pin-security-bypass-4-14-3/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e4fdc902-4cfe-4116-a294-9a0fcb2de346?source=cve
- https://blog.nintechnet.com/critical-vulnerability-fixed-in-wordpress-pinterest-automatic-plugin/
- https://wpscan.com/vulnerability/ffd344fd-de2c-4f27-8932-41aa0a3c3d05
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-pinterest-automatic-pin-security-bypass-4-14-3/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e4fdc902-4cfe-4116-a294-9a0fcb2de346?source=cve
Get alerted when CVE-2021-4380 or the next vulnerability affects your stack