What’s Vulnerable › Vulnerabilities
CVE-2021-43803: Unexpected server crash in Next.js
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 47.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-10 · updated 2026-06-17
- Weakness: CWE-20
Description
Next.js is a React framework. In versions of Next.js prior to 12.0.5 or 11.1.3, invalid or malformed URLs could lead to a server crash. In order to be affected by this issue, the deployment must use Next.js versions above 11.1.0 and below 12.0.5, Node.js above 15.0.0, and next start or a custom server. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js. Versions 12.0.5 and 11.1.3 contain patches for this issue.
Affected products
- Next.js: from 11.1.0 before 11.1.3; from 12.0.0 before 12.0.5 — fixed in 11.1.3, 12.0.5
How to fix
Upgrade to a fixed version: Next.js 11.1.3, 12.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/6d98b4fb4315dec1badecf0e9bdc212a4272b264
- https://github.com/vercel/next.js/pull/32080
- https://github.com/vercel/next.js/releases/tag/v11.1.3
- https://github.com/vercel/next.js/releases/v12.0.5
- https://github.com/vercel/next.js/security/advisories/GHSA-25mp-g6fv-mqxx
- https://github.com/vercel/next.js/commit/6d98b4fb4315dec1badecf0e9bdc212a4272b264
- https://github.com/vercel/next.js/pull/32080
- https://github.com/vercel/next.js/releases/tag/v11.1.3
- https://github.com/vercel/next.js/releases/v12.0.5
- https://github.com/vercel/next.js/security/advisories/GHSA-25mp-g6fv-mqxx
Get alerted when CVE-2021-43803 or the next vulnerability affects your stack