What’s Vulnerable › Vulnerabilities

CVE-2021-43808: Blade `@parent` Exploitation Leading To Possible XSS in Laravel

Description

Laravel is a web application framework. Laravel prior to versions 8.75.0, 7.30.6, and 6.20.42 contain a possible cross-site scripting (XSS) vulnerability in the Blade templating engine. A broken HTML element may be clicked and the user taken to another location in their browser due to XSS. This is due to the user being able to guess the parent placeholder SHA-1 hash by trying common names of sections. If the parent template contains an exploitable HTML structure an XSS vulnerability can be exposed. This vulnerability has been patched in versions 8.75.0, 7.30.6, and 6.20.42 by determining the parent placeholder at runtime and using a random hash that is unique to each request.

Affected products

How to fix

Upgrade to a fixed version: Laravel Framework 6.20.42, 7.30.6, 8.75.0; Packagist Illuminate/View 6.20.42, 7.30.6, 8.75.0; Packagist Laravel/Framework 6.20.42, 7.30.6, 8.75.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-43808 or the next vulnerability affects your stack