What’s Vulnerable › Vulnerabilities
CVE-2021-43810: Cross-site Scripting (XSS) when redirect an url
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Admidio is a free open source user management system for websites of organizations and groups. A cross-site scripting vulnerability is present in Admidio prior to version 4.0.12. The Reflected XSS vulnerability occurs because redirect.php does not properly validate the value of the url parameter. Through this vulnerability, an attacker is capable to execute malicious scripts. This issue is patched in version 4.0.12.
Affected products
- admidio: before 4.0.12 — fixed in 4.0.12
How to fix
Upgrade to a fixed version: admidio 4.0.12. Check the vendor advisory for mitigations.
References
- https://github.com/Admidio/admidio/commit/c043267d362f7813543cc2785119bf3e3e54fe21
- https://github.com/Admidio/admidio/commit/fcb0609abc1d2f65bc1377866bd678e5d891404b
- https://github.com/Admidio/admidio/releases/tag/v4.0.12
- https://github.com/Admidio/admidio/security/advisories/GHSA-3qgf-qgc3-42hh
- https://github.com/Admidio/admidio/commit/c043267d362f7813543cc2785119bf3e3e54fe21
- https://github.com/Admidio/admidio/commit/fcb0609abc1d2f65bc1377866bd678e5d891404b
- https://github.com/Admidio/admidio/releases/tag/v4.0.12
- https://github.com/Admidio/admidio/security/advisories/GHSA-3qgf-qgc3-42hh
Get alerted when CVE-2021-43810 or the next vulnerability affects your stack