What’s Vulnerable › Vulnerabilities
CVE-2021-4382: Recently <= 3.0.4 - Arbitrary File Upload to Remote Code Exectution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-434
Description
The Recently plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the fetch_external_image() function in versions up to, and including, 3.0.4. This makes it possible for authenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- hcabrera Recently: before 3.0.5 — fixed in 3.0.5
How to fix
Upgrade to a fixed version: hcabrera Recently 3.0.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2542693
- https://wpscan.com/vulnerability/92c3f26a-1a84-459a-874b-07dc83c9f42a
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-recently-multiple-vulnerabilities-3-0-4/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f8297149-2de3-4e49-80f9-6ea59dea6bce?source=cve
- https://plugins.trac.wordpress.org/changeset/2542693
- https://wpscan.com/vulnerability/92c3f26a-1a84-459a-874b-07dc83c9f42a
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-recently-multiple-vulnerabilities-3-0-4/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f8297149-2de3-4e49-80f9-6ea59dea6bce?source=cve
Get alerted when CVE-2021-4382 or the next vulnerability affects your stack