What’s Vulnerable › Vulnerabilities
CVE-2021-43827: Inline footnotes wrapped in <a> tags can cause errors in discourse-footnotes
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-14 · updated 2026-06-17
- Weakness: CWE-755
Description
discourse-footnote is a library providing footnotes for posts in Discourse. ### Impact When posting an inline footnote wrapped in `<a>` tags (e.g. `<a>^[footnote]</a>`, the resulting rendered HTML would include a nested `<a>`, which is stripped by Nokogiri because it is not valid. This then caused a javascript error on topic pages because we were looking for an `<a>` element inside the footnote reference span and getting its ID, and because it did not exist we got a null reference error in javascript. Users are advised to update to version 0.2. As a workaround editing offending posts from the rails console or the database console for self-hosters, or disabling the plugin in the admin panel can mitigate this issue.
Affected products
- discourse-footnote: before 0.2 — fixed in 0.2
How to fix
Upgrade to a fixed version: discourse-footnote 0.2. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse-footnote/commit/796617e0131277011207541313522cd1946661ab
- https://github.com/discourse/discourse-footnote/security/advisories/GHSA-58vr-c56v-qr57
- https://github.com/discourse/discourse-footnote/commit/796617e0131277011207541313522cd1946661ab
- https://github.com/discourse/discourse-footnote/security/advisories/GHSA-58vr-c56v-qr57
Get alerted when CVE-2021-43827 or the next vulnerability affects your stack